var n = 3;
for (var i = 0; i < n; i++) {
    console.log("問天地好在。");
}

原标题:文言文编制程序语言来了 可是好像比波兰语更难写了
来源:开源中中原人民共和国方今有开辟者开源了一门新的编制程序语言,吸引了大气开拓者的目光,短短几天得到了
3k+
star。该语言名叫“文言(wenyan-lang)”,这是一门接收文言文输入的编制程序语言,该语言不包罗葡萄牙共和国语字符,仅富含繁体汉语字符,并保留繁体引号“”。先看看
Helloworld
怎么写:吾有一數。曰三。名之曰“甲”。為是“甲”遍。吾有一言。曰“「問天地辛亏。”」。書之。云云。这段代码等效于以下
JavaScript
代码:var n = 3;for (var i = 0; i < n; i++卡塔尔(قطر‎ {console.log(“問天地还好。”卡塔尔国;}输出:問天地幸而。問天地幸好。問天地还好。同期,标点和换行符是完全可选的,与古粤语一致,所以地方的代码等效于:吾有一數曰三名之曰“甲”為是“甲”遍吾有一言曰“「問天地幸而”」書之云云Helloworld
看上去就算轻松,可是实际上作为一门编制程序语言,这里的语法都有严俊的定义:变量wenyanJavaScript吾有一數。曰三。名之曰“甲”。var
a = 3;有數八十。名之曰“大衍”。var dayan = 50;昔之“甲”者。今“大衍”是也。a
= dayan;吾有一言。曰“「噫吁戲”」。名之曰“乙”。var b =
“alas!”;吾有一爻。曰陰。名之曰“丙”。var c =
false;吾有一列。名之曰“丁”。var d =
[];吾有三數。曰一。曰三。曰五。名之曰“甲”曰“乙”曰“丙”。var
a=1,b=3,c=5;调整wenyanJavaScript若三大於二者。乃得“「想當然耳”」也。if
(3>2卡塔尔{ return “of course”;
}若三相当的小於五者。乃得“「想當然耳”」。若非。乃得“「怪哉”」也。if(3<=5卡塔尔国{return
“of course”}else{return “no way”}為是百遍。⋯⋯ 云云。for (var i = 0; i
< 100; i++卡塔尔{ … }恆為是。⋯⋯ 云云。while (true卡塔尔 { …
}凡“天地”中之“人”。⋯⋯ 云云。for (var human of world卡塔尔(قطر‎{ …
}乃止。break;运算wenyanJavaScript加一以二。1+2加一於二。2+1加一以二。乘其以三。(1+2卡塔尔国*3除十以三。所餘幾何。十分之一3減五百二十七以三百四十七。名之曰“甲”。var
a = 756-433;夫“甲”“乙”中有陽乎。a || b夫“甲”“乙”中無陰乎。a &&
b容器数组从 1
初阶索引。wenyanJavaScript吾有一列。名之曰“甲”。充“甲”以四。以二。var a
= []; a.push(4,
2);銜“甲”以“乙”。以“丙”a.concat(b).concat(c);夫“甲”之一。a[0]夫“甲”之其餘。a.slice(1);夫“玫瑰”之“「名”」。rose[“name”]夫“寶劍”之長。sword.length;函数wenyanJavaScript吾有一術。名之曰“玄天指”。是術曰。⋯⋯是謂“参合指”之術也。function
f(卡塔尔国{…}吾有一術。名之曰“六脈神劍”。欲行是術。必先得六數。曰“甲”。曰“乙”。曰“丙”。曰“丁”。曰“戊”。曰“己”乃行是術曰。⋯⋯是謂“六脈神劍”之術也。function
f(a,b,c,d,e,fState of Qatar{…}吾有一術。名之曰“翻倍”。欲行是術。必先得一數。曰“甲”。乃行是術曰。乘“甲”以二。名之曰“乙”。乃得“乙”。是謂“翻倍”之術也。function
double(aState of Qatar{var b = a * 2; return
b;}可是笔者表示上下文非亲非故的语法描述还在构建中。文言语言应用自然语言管理分享了古典中文语法,将语言编写翻译为
JavaScript 或 Python,何况图灵康健。同期它不只提供了一个配套在线
IDE,还提供了汪洋算法与数据构造示例,满含快排、Hanno塔难题与斐波那契数列表示等。—

在你编制程序语言的接纳上,你的主次将运营在何地是个决定性因素。

6. TextWrangler

图片 1

Text奥迪Q5 只怕是 Mac 平台上最佳的代码编辑器,它扶持 44
种编制程序语言,满含 JavaScript, Python, HTML, SQL 等。Text本田UR-V 出身贵族Bare Bones
Software,虽轻量却不失全能:语法高亮、智能搜索、代码折叠等等针对文本的批管理效率都有提供。

用作 BBedit 的后继,它在功用上做了有的简洁,贫乏 Markup,Clippings
成效,略有缺憾。但无需付费的优势让它同样成为多数开荒者的首荐,程序分界面清爽轻松,唯有常用功用,FTP/SFTP/AppleScript/Mac
OS UNIX 脚本之类高等功效藏在菜单里。

Text昂Cora 能轻易管理大意积的源代码文件,提供了广阔的效应,包蕴:

  • 帮助插件和宏
  • 安全的 FTP
  • 支持 SSH
  • 语法高亮
  • 机动达成
  • 拼写检查

Helloworld
看上去即使简单,然则实际上作为一门编制程序语言,这里的语法都有严格的定义:

Python

12. Araneae

图片 2

Araneae 仅帮助在 Windows
上采取,因其干净简单的分界面而被公众所知,它的简洁性让开垦者能自在编写代码。Araneae
是完全免费的软件。

提供了以下的成效:

  • 支撑流行的编制程序语言,满含 HTML,CSS,PHP,Rails,XHTML 等
  • 支撑 jEdit 等八个实例

文言文语言应用自然语言管理分享了古典汉语语法,将语言编写翻译为 JavaScript 或
Python,並且图灵完善。同有的时候候它不但提供了三个配套在线
IDE,还提供了多量算法与数据构造示例,包涵快排、Hanno塔难题与斐波那契数列表示等。

打闹开拓,以至

11. BBEdit

图片 3

也可以称作 Bare Bone Edit,该代码编辑器仅援助在 Mac
平台上利用,能够令你轻巧搜索,操作和编排代码。
试用版无偿下载使用,完整版本需求付费。

智能接口让 BBEdit 具备一等的效率,包括 grep
相配,寻觅和替换三个文本,项目概念的工具,成效导航和无数编制程序语言的语法高亮,代码折叠,FTP
和 SFTP 展开和封存,AppleScript 以至 Mac OS X 的 Unix
的剧本协助,代码自动补全,还会有一个刚劲的 HTML 工具配套。

BBEdit 提供以下职能:

  • 代码自动实现
  • 可分割的编辑撰写窗口
  • 语法高亮彰显
wenyan JavaScript
若三大於二者。乃得「「想當然耳」」也。 if (3>2){ return "of course"; }
若三不大於五者。乃得「「想當然耳」」。若非。乃得「「怪哉」」也。 if(3<=5){return "of course"}else{return "no way"}
為是百遍。⋯⋯ 云云。 for (var i = 0; i < 100; i++){ ... }
恆為是。⋯⋯ 云云。 while (true) { ... }
凡「天地」中之「人」。⋯⋯ 云云。 for (var human of world){ ... }
乃止。 break;

率先,无须设置任杜修斌西。你能够张开文本编辑器然后开始输入 JavaScript
。代码将在您的浏览器中运作。最拔尖的浏览器内置了JavaScript
引擎,所以您的代码将得以运作在差相当少具备的Computer和无数的移动器械上。事实上,能即时在浏览器中运营代码为编制程序职员提供了一个不胜快的举报,这对于生手来讲是很好的。你能品尝一些职业然后急忙地来看结果。

2. Chocolat

图片 4

Chocolat 是 Mac 平台上一款强盛的代码编辑器,包容原生的 Cocoa
及具有强盛的文本编辑功用。Chocolat
目的在于与系统无缝集成,它帮助广大编制程序语言的语法高亮。Chocolat 为
JavaScript, Python 和 HTML
文件提供拖拽成效,只须求拖拽文件也许文件夹到软件分界面就能够。Chocolat
还扶持窗口分割、标签页、色彩主题等职能。分界面和 MacVim 极度相仿。

一对别样的作用:

  • 品种寻觅和转移
  • 实时错误检查实验

图片 5

从实质上讲,一门编制程序语言的语法正是您所输入的能让那编制程序语言试行的开始和结果。那满含单词,特殊字符,空格恐怕以上大肆的结合。Python
尽大概地使用德文,不像其它编制程序语言那样时常应用标点符号大概极度的字符。所以,Python
阅读起来更自然、更疑似人类语言。那或多或少相助新的编程职员可以聚集于化解难题,而能花费越来越少的日子纠葛于言语本人的特色上。

三个好的代码编辑器不止是一个简约的文本编辑工具,那是产生神迹之处,开采者编写的代码会转接为越来越大的花色的可用组件。鉴于这一首要,难怪开辟者会对与她们日夜共处的代码编辑器如此责难。种种开拓者都梦想保有一个便捷、易于使用且意义均衡的代码编辑器。

容器

职能上两个对等,并且都能运作。{} 和 ;
告诉大家哪儿是代码块的分裂部分。但是,第三个对于大家来讲断定更便于阅读。相比较之下达成相似效果的
Python 是如此的:

每种代码编辑器都会注明本人是最棒的,但是你须要的大概只是独一一款代码编辑器。上边是有的主流的、美评度高的代码编辑器,各位开垦者不要紧看看是否有合乎本身的。

wenyan JavaScript
吾有一列。名之曰「甲」。充「甲」以四。以二。 var a = []; a.push(4, 2);
銜「甲」以「乙」。以「丙」 a.concat(b).concat(c);
夫「甲」之一。 a[0]
夫「甲」之其餘。 a.slice(1);
夫「玫瑰」之「「名」」。 rose["name"]
夫「寶劍」之長。 sword.length;

桌面应用是运作在台式机或许台式机Computer上的人生观软件程序。那样您编写的代码在同期内只好在一台Computer上运转。移动接收,也正是我们所熟知的app,运维在运用
IOS 、Android 或许别的操作系统的移动设备上。网页应用是成效像应用的网页。

10. jEdit

图片 6

jEdit 自称是为严刻的技术员创设的一款严刻编辑器。它是一款应用 Java
开采的开源项目(可随机使用),在 GPL 执照下宣布。它能够在
Windows、Linux、Mac
等几种阳台下运维,并且有超多插件,能够扩展底蕴效。它也支撑 80
三种文件类型的语法高亮呈现。帮忙包含 UTF-8 在内的各类字符编码。

jEdit 有很平价的宏定义作用,能够用 BeanShell、Jython 和 JavaScript
等脚本语言。

除花销持 100+ 的插件和宏,还可能有一部分名特别减价的效果:

  • 经过第三方插件集成编写翻译器
  • 扶持 FTP 与集成 FTP 的浏览器
  • 拼写检查
wenyan JavaScript
加一以二。 1+2
加一於二。 2+1
加一以二。乘其以三。 (1+2)*3
除十以三。所餘幾何。 10%3
減七百五十六以四百三十三。名之曰「甲」。 var a = 756-433;
夫「甲」「乙」中有陽乎。 a || b
夫「甲」「乙」中無陰乎。 a && b

可能,疑似这样:

0. Vim

图片 7

Vim
是最流行的代码编辑器之一。它是无需付费开源且跨平台的,称它为代码编辑器中非常了不起非凡的上古神器也不为过。特别是在
Linux 开荒者中,它具备一定高的人气。Vim 高度可定制,还可在 Dos 中运维。

在刚入门开采的部落中 Vim
大概不会要命流行,因为它的入门学习曲线陡峭。下边是 Vim 附带的有些功能:

  • 集成的 UI
  • 扶植超越 200 种语言的语法高亮
 問天地好在。
問天地好在。
問天地好在。

后台开拓,相当于我们所纯熟的劳务器端开垦,编写的代码运转在您不恐怕实际接触的服务器上。

1. Light Table

图片 8

Light Table
是另二个免费开源的代码编辑器,它有三个可怜轻便干净的分界面,以至大批量的扩大。Light
Table 相同与 Windows, Mac 和 Linux 那多少个主流平台包容,并且中度可定制。

动用 Light
Table,客户可实时见到产生的成形。该编辑器超轻量,而且协助分化的放松权利。Light
Table 致力于营造三个便于上手,但同样切合专业的强硬的编制程序境遇。

Author

发表评论

电子邮件地址不会被公开。 必填项已用*标注